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1 Introduction to QGIS 

 

For those unfamiliar with Quantum GIS (QGIS), it is a user friendly Open Source Geographic 

Information System (GIS) which lets you browse, edit and create a variety of vector and raster 

formats, including ESRI shapefiles, spatial data in PostgreSQL/PostGIS, GRASS vectors and rasters, or 

GeoTiff. * 

You can create customised plugins and GIS enabled applications using Python or C++ programming 

languages.* 

*http://www.osgeo.org/QGIS   

The QGIS interface is split into six areas; The Menu bar (Red), the key tools toolbar (light blue), the 

advanced toolbar (green), the map legend (yellow) the browser (dark blue) and the map view 

(purple).  

 

Your most often used sets of tools can be turned into toolbars for basic access. For example, the File 

toolbar allows you to save, load, print, and start a new project. You can easily customize the 

interface to see only the tools you use most often, adding or removing toolbars as necessary via the 

View > Toolbars menu. 

Even if they are not visible in a toolbar, all of your tools will remain accessible via the menus. For 

example, if you remove the File toolbar (which contains the Save button), you can still save your map 

by clicking on the File menu and then clicking on Save. 

http://www.osgeo.org/QGIS
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The status bar at the bottom of the QGIS window shows you information about the current map. It 

also allows you to adjust the map scale and see the mouse cursor’s coordinates on the map. 

 

 

 

Short exercise! 

For this exercise, open the QGIS project ‘Habitats’. 

Below are some of the key functions in the main toolbar try to find these in QGIS and explore their 

functions.  
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1.1 Data types  

There are two spatial data types available for use within a GIS; Raster and vector data. Raster data 

represents continuous surfaces, while vector data can be representative of points, lines and discrete 

areas. In this section of the training course vector data will be used for the analysis and display of 

agricultural land cover in QGIS. 

For your information, here are the possible projection types you might encounter – being aware of 

the projection you are working with can prevent issues with compatibility between data layers. 

EPSG:26719 - NAD27 / UTM zone 19N 

EPSG:4326 - WGS 84 

1.2 Datasets 

 

There are three datasets required for this exercise; 

 PROVO-PARCELS-2009.shp 

 Provo_points.shp 

 Provo_raster.jp2 

The first two datasets are shape files (.shp). However, PROVO-PARCELS-2009.shp is a polygon based 

shape file, while Provo_points.shp is a point based vector. The Provo_raster.jp2 file is a raster 

dataset which means it is an image. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2. PROVO-PARCELS-2009.shp 
polygon vector data 

 

Figure 1. How Provo_points.shp point 
data look when displayed 

Figure 3. Provo_raster.jp2 raster data 



Environment Systems Ltd. – GIS analysis 
Page 6 of 22 

 

 

 

2 Exercise: Developing datasets 

 

2.1 Displaying raster data in QGIS 

Import raster data into a new QGIS project using the ‘Add Raster Layer’ Icon: 

 

Using the ‘Add raster layer’ window and selecting ‘Browse’ the user can navigate to the raster data 

layers desired, in this case Provo_raster.jp2. 
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2.2 Displaying vector data in QGIS 

 

Import vector data into a new QGIS project using the ‘Add Vector Layer’ Icon: 

 

Using the ‘Add vector layer’ window and selecting ‘Browse’ the user can navigate to the vector data 

layers desired, in this case PROVO-PARCELS-2009.shp and Provo_points.shp.  

 

 

Select and open the desired datasets.  

 

 

 

 

 

Attribute table 

The Provo_points.shp layer provides the information for various amenities located on this island.  

FEATURE tells us what facility is at that location.  

To view the scoring right click on the data layer: Agri_points.shp and select open attribute table. 
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Colouring the map 

 

In order to view the attributes of the datasets: 

- Double click the name of the dataset in the ‘Layers’ window in QGIS. The layer properties 

window will appear.  

- Within this window, select the ‘Style’ tab.  

- In the first drop down menu select ‘categorized’ 

- In the second drop down menu entitled ‘Column’ select the category of the data desired. 

For the Provo_points.shp data this will be ‘FEATURE’. 

- Select classify 

The classes will appear in the window and in the shape file displayed in QGIS.   

 

For ways to edit the colours for each class in order to represent your data more appropriately, refer 

to Section 2.4. 

 

 

 

 



Environment Systems Ltd. – GIS analysis 
Page 9 of 22 

 

2.3 Merging attributes 

 

In this exercise we are looking at districts. In this exercise you want to find which districts have a 

school to start an information campaign amongst the children  

Under the ‘Vector’ option in the main toolbar in QGIS, select ‘Data Management Tools’> ‘Join 

Attributes by Location’.  
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Name and save as appropriate, for example ‘Prov_Amenities.shp’. Where the point and polygon 

data correspond, new polygons will have been created, telling you which districts have schools 

within them. 
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2.4 Editing display 

 

Changing the colours of the map 

The colouring of the polygons can also be edited for display purposes. Appropriate colour for map 

display can be important, particularly when displaying values of features.  

To edit the display colours of the shape files, double click on the desired layer and navigate to the 

‘style’ tab. Individual classes can be edited by double clicking the colour square in the ‘Symbol’ 

column. 

  

Use the symbol editor to change individual class colours and border styles.  

 

 

In order to change the colours of all classes, colour ramps can be created and applied. Alternatively, 

the user can select all the classes by holding the ‘Shift’ button and selecting classes, then clicking 

‘Change’, which will allow manual changing of all the classes display properties.  
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3 Exercise: Understanding selection queries 

 

In this scenario we will be looking at fish catch data to find information about a specific species. 

Selecting features – Query builder 

The query builder lets us run more complex selections on the data. Let’s run through one with the 

Provo Points layer where we will select the schools 

Click the query builder icon  

- Select the Provo_Points  layer in the Layers list. 

- Click the query builder icon  on the tool bar. 

- Look down in the Function list  on the left of this dialog until you see the Fields and 

Values. 

- Click on the plus. 

- You will now see a list of your fields from the attribute table. 

 

Now we need to tell QGIS to only show us the features where the value of FEATURE is equal to 

School. 

- Double-click the word FEATURE in the Fields  list. 

- Watch what happens in the Expression  field below: 
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The word “FEATURE” has appeared! To build the rest of the query: 

- Click the = button (under Operators). 

- Click on the Load all unique values button beneath the Values field.  This will show 

you the different values contained in the FEATURE attribute. 

- Double-click the value School in the Values  list. 

Your query is this: 

 

And now click Select 

 

For further analysis, it’s better if we’ve got the selection features as a separate layer. 

- Right-click on the Provo_Points  layer and click Save As...  

- Next to the Save as field in the dialog that appears, click the Browse  button. 

- Save the layer within the exercise folder. 

- Check the Add saved file to map  box in the Save vector layer as... dialog. 

- Click OK. It will tell you that Export to vector file has been completed. 

- Click OK. 

 

Additional 

Now create a separate dataset each for hotels and churches. 

 

 

 

 

 



Environment Systems Ltd. – GIS analysis 
Page 15 of 22 

 

4 Exercise: Adding a Data table and Joining Layers 

 

The data sets being used for this section of the Exercise are: 

 Islands.shp  

 Hotel_Count.csv 

Open QGIS Desktop 2.4.0 and add the Vector layer Islands.shp 

To add a table pan to the left hand toolbar and select the ‘Add delimited text layer’ icon. 

Select the icon. A dialog box will appear from which you can navigate to the Hotel_Count.csv file.  

Select the ‘CSV (comma separated values)’ button and the ‘no geometry (attribute only table)’ 

Select ok and check in the map legend that the table has uploaded. 
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To perform the join between the two data layers ‘right click’ on the Habitat map in the map legend.  

Scroll down the list to ‘Properties’ and select. A dialog box will appear. In the left hand column select 

the Join icon and subsequently the add icon   

The dialog box that shows provides options for which layers to join to the Islands and what fields to 

use to perform the match (Join field and Target field).  Select: 

 Join layer: Hotel_Count 

 Join field: ISLAND 

 Target field: ISLAND 

 Select ok and navigate to the map layers. Right click on Island layer and scroll down to open the 

attribute table.  

There should now be a new field called Count that provides the total number of hotels on each 

island. 
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To save the shapefile with the additional information, scroll to the map legend, right click on the 

Islands layer and move down to ‘save as’.  

Select and location and name to save the shapefile under and ensure the projection (CRS) is correct. 

In this case it is NAD27/ UTM Zone 19N. 

 

 

 

 

 

 

 

 

 

 



Environment Systems Ltd. – GIS analysis 
Page 18 of 22 

 

5 Exercise: Vector Processing 

 

Identifying areas of land close to the coast 

It has been decided that roads within 200m of the coast will be considered as at risk for the purposes 

of this analysis.  To identify these areas we will use a Buffer operation, found in the Geoprocessing 

Tools menu, under the Vector menu, upon the Sea_poly layer.    

  

 

Open the Buffer dialogue window and set the Input Vector Layer to Sea_poly.  Ensure that the 

Buffer distance option is highlighted and that the distance field is set to 200m.  Tick the Dissolve 

buffer results option and use the Browse button to save the output shapefile in a sensible 

location.  Call the shapefile  Sea_poly_buffer200.shp  and tick the Add result to canvas option. 
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Identify roads that are within 200m of the sea 

In the final step we will use an overlay operation to discover which roads fall within the 200m sea 

buffer. 

We will be using the Clip operation found in the Geoprocessing Tools menu, this time to clip your 

Island_roads Input vector layer by the Sea_buffer200 layer.  Call the output shapefile 

Highrisk_Roads. 
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The results of this operation should give you a layer that looks like this: 

 

 

 

 

Additional Exercise 

Load in the contour data! 

Can you identify the roads that are not only within 200m of the sea, but also below 2m in height 

and, therefore, at particular risk of being affected by storm surges? 
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6 Installing and managing plugins 

GIS has many analysis capabilities but to work with some of these we need to load special modules 

called ‘plugins’  To begin using plugins, you need to know how to download, install and activate 

them. To do this, you will learn how to use the Plugin Installer and Plugin Manager. 

The goal for this session: To understand and use QGIS’ plugin system. 

First of all look at the Raster and Vector menus and note the number of options available. 

Managing plugins 

To open the Plugin Manager, click on the menu item Plugins ‣ Manage and install Plugins. 

This window shows all the currently installed plugins: 

 

You can activate and deactivate plugins by clicking in the box next to the plugin. 

Importantly, however, the list of plugins that you can activate and deactivate only draws from the 

plugins that you currently have installed. To install new plugins, you need to use the Plugin Installer. 

Installing new plugins 

From the window you opened in the previous step, select Get More. 

The window will now change and the amount of plugins that you see here will differ, depending on 

your setup. 

The plugins that are available to you for installation depend on which repositories you are checking. 
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QGIS plugins are stored online in repositories. By default, only the official repositories are active, 

meaning that you can only access official plugins. These are usually the first plugins you want, 

because they have been tested thoroughly and are often included in QGIS by default. 

 

Look through these plugins and see if any look of particular interest to you.   

You can install a plugin by selecting it then pressing Install/upgrade plugin. 

Exercise 

Use the Research tool below to plan sampling points for a monitoring evaluation: 

 


